Where is coolant temp sensor?

For any Leon questions including modifications, tuning, I.C.E, problems etc

Where is coolant temp sensor?

Postby silverfox on Tue Aug 08, 2006 4:20 pm

I've diagnosed a faulty coolant sensor using vag-com and have ordered and received a replacement. Could someone explain how I go about replacing it. I've been told it only takes 10minutes so I figured I'd manage myself, where should I be looking for this sensor? Near the expansion tank I presume?

Any help or pics would be appreciated?

Thank You
silverfox
 
Posts: 229
Joined: Thu Apr 08, 2004 12:00 pm

Advertisement

Postby Ianf on Tue Aug 08, 2006 4:31 pm

If you look at the right side of the engine, from the front, it should be above the gear box if i remember correctly. If you are removing it watch the u clip doesnt ping off and do it with the engine cold as the coolant gets pretty warm.
Ianf
 
Posts: 1445
Joined: Sat Oct 18, 2003 12:00 pm
Location: glasgow

Postby silverfox on Tue Aug 08, 2006 4:57 pm

On the right hand side from the front!?? So it's nowhere near the expansion tank then??!

Just as well I asked then eh?

Thanks
silverfox
 
Posts: 229
Joined: Thu Apr 08, 2004 12:00 pm

Postby DodgyDave on Tue Aug 08, 2006 8:52 pm

Yea as Ian says :)

Looking from the front of the car it's on the Right Hand Side of the engine (towards the front half), above the gearbox.

On my 180phb (AUQ) you also had to remove the small plastic trim that goes along the front & right hand side of the engine to get to it.

Again as Ian says be carefull of the clip, it'll ping away very easily. Sensor pulls straight out.

Also to save you from having to drain the whole engine coolant, open the expantion tank and let the preasure equalise then shut it again, when you remove the sensor you'll lose only about a cup-full of coolant :)


Dave
DodgyDave
 
Posts: 1673
Joined: Mon Mar 01, 2004 12:45 pm

Postby Pabs on Tue Aug 08, 2006 9:33 pm

don't get the coolant level sensor and coolant temp sensor mixed up like i did (mentally)...

As said, its down the right hand side of the engine, just below the engine cover (not the main one, the thin one).
Pabs
 
Posts: 3705
Joined: Fri Dec 31, 2004 12:00 pm

Postby DodgyDave on Tue Aug 08, 2006 9:39 pm

lol pabs ......

Your comment mad me re-read this whole thread... just to make sure :)


Dave
DodgyDave
 
Posts: 1673
Joined: Mon Mar 01, 2004 12:45 pm

Postby silverfox on Wed Aug 09, 2006 11:50 am

Brilliant guys, thanks a lot!

I know where i'm looking now. The more I read threads about dodgy coolant sensors, the more I think this is going to sort quite a few little issues I've been having, lumpiness, mpg, power inconsistencies.

DodgyDave, mine is an AUQ engine code also.
silverfox
 
Posts: 229
Joined: Thu Apr 08, 2004 12:00 pm

Postby DodgyDave on Wed Aug 09, 2006 6:51 pm

Yup .. coolant sensor (and MAF) are what i changed a while back, was getting the same as you at the time.


Dave
DodgyDave
 
Posts: 1673
Joined: Mon Mar 01, 2004 12:45 pm


Return to Leon

Who is online

Users browsing this forum: Yahoo [Bot] and 5 guests