SEAT Automobiles Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
400 Posts
Discussion Starter · #1 ·
Right, Yesterday I got in the car to drive to work and when indicating to turn right I got NOTHING. Then leave work early intending to go to the garage, to get it looked at and it works again.
Thought it was a one off but then this morning exactly the same. Again this evening they work. :baffled5wh: Any ideas? The left indicator works fine all the time. I think it may be a loose wire or something, as I can get it to work in the morning if I push the stalk up a little further than normal.
Help..... :eek:o7dt:
 

·
Registered
Joined
·
400 Posts
Discussion Starter · #7 ·
Been to Seat this morning. They are quoting £45 for the part so I'd rather pay an extra few £££'s to get a new one. I know the chief mechanic so hopefully he'll get me a discount on fitting etc. Great spot tho. Cheers
 

·
Registered
Joined
·
400 Posts
Discussion Starter · #8 ·
Right had it looked at this morning. They tested all the electrical connections etc and they are all fine. So it's booked in for next Saturday to be done. £90 down the pan!!! Oh well cheaper than having a crash or being pulled over and getting points and a fine.
 

·
Registered
Joined
·
427 Posts
we had that (or someting like it). they looked at it and there was no fault. we drove around for over a year with a broken indicator. they bent the wires on the back of the casing a bit as a temporary fix while they ordered new casing. But there temporary solution worked fine and now they are stuck with the casing.
 
1 - 9 of 9 Posts
Top