SEAT Automobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi - can anyone help with this I wonder?

My Leon 1.6 started stalling while driving about 10 days ago and wouldn't restart so we had it recovered to a local garage. They diagnosed a temperature sensor & also found that the cam belt tensioner had shattered as well so did the belts.

Anyway, now when the engine starts from cold it seems to be hunting and then when it warms up (after 2 or 3 miles) it stalls when at idle. You can restart it the first time but after that you have to wait until it is cold to start again. Nothing is showing up on their diags now.

The mechanic has run out of options & suggests to take it to a dealership but it means more delays and more cost.

Anyone got any ideas?
Thanks,
Ed
 

·
Registered
Joined
·
137 Posts
Sounds like the MAF sensor might be on it's way out as I had the same problem recently. As far as I know only a main dealer can diagnose this for sure. Mine started out running rough and eventually wouldn't run at all, so to save yourself tow costs you may as well spend a few quid on diagnostics.
 

·
Registered
Joined
·
2,310 Posts
Hunting is when the revs constantly rise and fall on idle rather than running smoothly at the same speed. If an engine hunts really badly the revs will drop so low it stalls
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top